Changes to the e-LfH hub and Internet Explorer - e-Learning for Healthcare
Menu Access our e-learning programmes on the e-LfH Hub Hub Register / Log in >

Changes to the e-LfH hub and Internet Explorer

Alex Drinkall, 9 April 2018
e-LfH_Blog

e-Learning for Healthcare (e-LfH) resources are no longer supported by Microsoft’s Internet Explorer versions 8, 9 and 10.

This decision will bring e-LfH’s browser policy in line with other NHS organisations, including Electronic Staff Record (ESR).

The current version of Internet Explorer, version 11, and Microsoft’s Edge will continue to be supported.

Over the last few years the usage of these older versions of browsers has reduced significantly to less than 2% of all e-LfH accessed sessions. If your organisation still uses these older Internet Explorer versions, please note that alternative browsers such as Chrome or Firefox can be used. Please refer to your local IT department for assistance in using a different browser.

Ceasing support of the older versions of Internet Explorer will enable e-LfH to develop and test new functionality, without the restrictions of considering aging technologies.

e-LfH is still supporting the following browsers:

PC

  • IE11
  • Edge (latest version)
  • Chrome (latest version)
  • Firefox (latest version)

Mac

  • Chrome (latest version)
  • Firefox (latest version)
  • Safari (latest version)

Android

  • Chrome (latest version)

iOS

  • Safari (latest version)

If you have any questions about this change please contact the e-LfH helpdesk: Support Form

Comments are closed.

e-LfH is a Health Education England Programme in partnership with the NHS and Professional Bodies